Welcome Guest ( Log In | Register )


 
 
 
 
 
 

 
 
Oracle 

Performance Tuning Reference poster
 
Oracle training in Linux 

commands
 
Oracle training Weblogic Book
 
Easy Oracle Jumpstart
 
Oracle training & performance tuning books
 
Burleson Consulting Remote DB Administration
 
 
 
Reply to this topicStart new topic
> Product User Profile - Remote database conn
M K Krishnan
post Jan 9 2008, 12:12 AM
Post #1


Newbie
*

Group: Members
Posts: 3
Joined: 8-January 08
Member No.: 15,854



I have Oracle 9i installed on windows XP . I created a user and I am able to login. I have created a Net service name in Oracle Net manager .

The connection is tested with remote Unix Oracle Database with user-id from Net manager.

Now from Windows system, I give Sqlplus user_id@<service_name>/password
it throws an error

Product user Profile Information is not loaded.

Can any one help in this regard.

I executed PUPBLD.sql from system user. But still I am not able to connect remote database (unix) user.

M K Krishnan
Go to the top of the page
 
+Quote Post
burleson
post Jan 9 2008, 08:32 AM
Post #2


Advanced Member
***

Group: Members
Posts: 11,808
Joined: 26-January 04
Member No.: 13



>> I executed PUPBLD.sql from system user.


Check this a similar error:

http://dba.ipbhost.com/index.php?showtopic=3726

>> it throws an error

Can you provide some more details?
Are you positive that you were connected as SYSTEM and not as SYSDBA?


--------------------
Hope this helps. . .

Donald K. Burleson
Oracle Press author
Author of Oracle Tuning: The Definitive Reference
Go to the top of the page
 
+Quote Post
M K Krishnan
post May 15 2008, 02:22 AM
Post #3


Newbie
*

Group: Members
Posts: 3
Joined: 8-January 08
Member No.: 15,854



I am working on Windos XP SP2. Oracle 9i is installed on this Windows XP system.

I have connectivity to Sun Solaris system on whcih Oracle 7.2 database is installed. I have a
an oracle user in sunsolaris system.
From DOS prompt of Windows XP system , I am trying to connect to my user-id in oracle 7.2 database.


C:\>sqlplus

SQL*Plus: Release 9.2.0.1.0 - Production on Thu May 15 12:52:00 2008

Copyright © 1982, 2002, Oracle Corporation. All rights reserved.

Enter user-name: rishi@rmtdb
Enter password:
Error accessing PRODUCT_USER_PROFILE
Warning: Product user profile information not loaded!
You may need to run PUPBLD.SQL as SYSTEM


I have executed PUPBLD>sql from SYSTEM user. Still I am getting the same ERROR.

can anyone help in this regard.?.
Go to the top of the page
 
+Quote Post
burleson
post May 15 2008, 06:27 AM
Post #4


Advanced Member
***

Group: Members
Posts: 11,808
Joined: 26-January 04
Member No.: 13



Hi,

The Oracle docs note:

The PRODUCT_USER_PROFILE (PUP) table provides product-level security that supplements the user-level security provided by the SQL GRANT and REVOKE commands and user roles. To create the PUP table, log in to SQL*Plus as the SYSTEM user and run PUPBLD.SQL which is located in the ORACLE_HOME\SQLPLUS\ADMIN directory with:

SQL> @%ORACLE_HOME%\SQLPLUS\ADMIN\PUPBLD.SQL



>> Warning: Product user profile information not loaded!

See here: http://www.dba-oracle.com/t_warning_produc..._not_loaded.htm

Also, note that the product_user_profile must be owned by SYSTEM, and you will get an error if you run pupbld as SYS.


--------------------
Hope this helps. . .

Donald K. Burleson
Oracle Press author
Author of Oracle Tuning: The Definitive Reference
Go to the top of the page
 
+Quote Post
M K Krishnan
post Aug 5 2008, 03:58 AM
Post #5


Newbie
*

Group: Members
Posts: 3
Joined: 8-January 08
Member No.: 15,854



QUOTE (M K Krishnan @ May 15 2008, 07:23 AM) *
I am working on Windos XP SP2. Oracle 9i is installed on this Windows XP system.

I have connectivity to Sun Solaris system on whcih Oracle 7.2 database is installed. I have a
an oracle user in sunsolaris system.
From DOS prompt of Windows XP system , I am trying to connect to my user-id in oracle 7.2 database.
C:\>sqlplus

SQL*Plus: Release 9.2.0.1.0 - Production on Thu May 15 12:52:00 2008

Copyright 1982, 2002, Oracle Corporation. All rights reserved.

Enter user-name: rishi@rmtdb
Enter password:
Error accessing PRODUCT_USER_PROFILE
Warning: Product user profile information not loaded!
You may need to run PUPBLD.SQL as SYSTEM
I have executed PUPBLD>sql from SYSTEM user. Still I am getting the same ERROR.

can anyone help in this regard.?.



Hi,

I am not able to come out of the problem 'Error Accessing Product User_profile"

Can anyone help me ?

PUPBLD.sql is executed from SYSTEM user. Still No scope.

Krishnan
Go to the top of the page
 
+Quote Post
aussie_dba
post Aug 5 2008, 04:49 AM
Post #6


Advanced Member
***

Group: Members
Posts: 619
Joined: 28-August 04
Member No.: 495



"Can anyone help me ?"

They did. They gave you a complete solution to the issue.

"Still I am getting the same ERROR."

ERROR? Are you really a DBA? The PUP message is a a warning, not an error:

CODE
"Warning: Product user profile information not loaded!"


If the table truly exists, your problem is likely a missing synonym, or you have multiple tables in other schemas.
Go to the top of the page
 
+Quote Post
dave
post Aug 5 2008, 05:02 AM
Post #7


Advanced Member
***

Group: Members
Posts: 5,208
Joined: 8-October 04
Member No.: 785



QUOTE (M K Krishnan @ Aug 5 2008, 09:59 AM) *
Hi,

I am not able to come out of the problem 'Error Accessing Product User_profile"

Can anyone help me ?

PUPBLD.sql is executed from SYSTEM user. Still No scope.

Krishnan


run it again as system, show the proff here - becuase you probably did it wrong
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

Lo-Fi Version Time is now: 19th December 2014 - 10:41 PM