Welcome Guest ( Log In | Register )


 
 
 
 
 
 

 
 
Oracle 

Performance Tuning Reference poster
 
Oracle training in Linux 

commands
 
Oracle training Weblogic Book
 
Easy Oracle Jumpstart
 
Oracle training & performance tuning books
 
Burleson Consulting Remote DB Administration
 
 
 
Closed TopicStart new topic
> Problema com o Oracle text ao executar a consulta pela 1x
Rafael Pinheiro
post Apr 10 2012, 05:13 PM
Post #1


Newbie
*

Group: Members
Posts: 4
Joined: 10-April 12
Member No.: 47,062



Boa noite!!

Eu estou começando a trabalhar com oracle text e estou com um problema.

As consultas estão lentas ao executá-las pela primeira vez. As vezes, ocorre erro de timeout. A cláusula da consulta segue abaixo:

( CONTAINS(texto,'tc OR {turbo-compressor} OR turbocompressor',1) > 0 )

Ao executar a mesma consula por 2 ou mais vezes, não acontece nenhum problema.

Alguém sabe me dizer o porque deste problema?

Obrigado!
Rafael Pinheiro
Go to the top of the page
 
+Quote Post
burleson
post Apr 11 2012, 06:49 AM
Post #2


Advanced Member
***

Group: Members
Posts: 11,326
Joined: 26-January 04
Member No.: 13



Hoi Rafief,



I had to translate this:
Good night! I am starting to work with oracle text and am with a problem.

>> The consultations are slow for the first time when executing them.

Get an execution plan for the SQL:

http://www.dba-oracle.com/t_sql_execution_plan_tips.htm

******************************************
The times, occur error of timeout.

What specific error number?

*****************************************************

>> When executing same consula for 2 or more times, does not happen no problem.

Because the blocks are in the RAM buffer.

http://www.dba-oracle.com/art_tuning_instance.htm

Please post in English . . . .




--------------------
Hope this helps. . .

Donald K. Burleson
Oracle Press author
Author of Oracle Tuning: The Definitive Reference
Go to the top of the page
 
+Quote Post
Rafael Pinheiro
post Apr 11 2012, 03:17 PM
Post #3


Newbie
*

Group: Members
Posts: 4
Joined: 10-April 12
Member No.: 47,062



Hi,

When i execute the query for the fisrt time, occurs the error ORA-01013...

After the first execution of query, the response for the same query is very fast...

Why this happens?

P.S: The indexes of Oracle text were created as follow above:

create index ie02_text on doc(full_doc) indextype is ctxsys.context parameters ('sync (on commit)');


Go to the top of the page
 
+Quote Post
burleson
post Apr 11 2012, 04:06 PM
Post #4


Advanced Member
***

Group: Members
Posts: 11,326
Joined: 26-January 04
Member No.: 13



Hi Rafael,


>> 'sync (on commit)'

Do you really want to have this HUGE overhead? Context indexes are mostly for READ ONLY tables . . .

Context indexes can take a great deal of time to create and during the index build there MUST BE NO updating of the database.

Your ORA-01013 was a timeout, waiting for a row to be released.

http://www.dba-oracle.com/t_ora_01013_user...t_operation.htm

**********************************************
>> After the first execution of query, the response for the same query is very fast...

Like I said, it's is loading your data buffers.


--------------------
Hope this helps. . .

Donald K. Burleson
Oracle Press author
Author of Oracle Tuning: The Definitive Reference
Go to the top of the page
 
+Quote Post
Rafael Pinheiro
post Apr 11 2012, 04:53 PM
Post #5


Newbie
*

Group: Members
Posts: 4
Joined: 10-April 12
Member No.: 47,062





the table that has the index is updated every night by only a pl/sql. What should i do to solve this problem? change the parameter?
Go to the top of the page
 
+Quote Post
Rafael Pinheiro
post Apr 11 2012, 05:29 PM
Post #6


Newbie
*

Group: Members
Posts: 4
Joined: 10-April 12
Member No.: 47,062



can i use the parameter 'SYNC (EVERY "SYSDATE+1/24")'?
Go to the top of the page
 
+Quote Post
burleson
post Apr 12 2012, 10:10 AM
Post #7


Advanced Member
***

Group: Members
Posts: 11,326
Joined: 26-January 04
Member No.: 13



Drop the index, load with PL/SQL and re-build the Context index nightly.

>> What should i do to solve this problem?

If the table is read-only the refresh does not matter but see here:

http://dba-oracle.com/oracle_tips_like_sql_index.htm

>> can i use the parameter 'SYNC (EVERY "SYSDATE+1/24")'?

Try it and see


--------------------
Hope this helps. . .

Donald K. Burleson
Oracle Press author
Author of Oracle Tuning: The Definitive Reference
Go to the top of the page
 
+Quote Post

Closed TopicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

Lo-Fi Version Time is now: 28th July 2014 - 05:18 AM