Welcome Guest ( Log In | Register )


 
 
 
 
 
 

 
 
Oracle 

Performance Tuning Reference poster
 
Oracle training in Linux 

commands
 
Oracle training Weblogic Book
 
Easy Oracle Jumpstart
 
Oracle training & performance tuning books
 
Burleson Consulting Remote DB Administration
 
 
 
Reply to this topicStart new topic
> Database creation: Warning ORA-00119, ORA-00132
1stone
post Mar 15 2017, 09:45 AM
Post #1


Newbie
*

Group: Possible Spammers
Posts: 1
Joined: 15-March 17
Member No.: 51,834



Hello,

I am using SUSE Linux Enterprise Server 11 SP4 and I used the following guide to install and configure Oracle Grid (12.2.1) and Oracle Database 12c Release 1 (12.1.0.2):
http://www.idevelopment.info/data/Oracle/D.../LINUX_22.shtml

Installation of Oracle Grid as well as the installation of the Database software finished without issues. Unfortunately the creation of a new database is producing some warnings during the database creation process:
Attached File  2017_03_15_150552.png ( 182.86K ) Number of downloads: 1


I am attaching the following files, so you can see how the setup looks like:
listener.ora: Attached File  listener.ora.txt ( 339bytes ) Number of downloads: 0

tnsnames.ora: Attached File  tnsnames.ora.txt ( 411bytes ) Number of downloads: 0

and the .bash_profile: Attached File  bash_profile.txt ( 9.7K ) Number of downloads: 0



According to this article (http://dba-oracle.com/bk_ora_00119.htm) I decided to modify the SPFILE/PFILE. First I tried to get an overview which files are located in ASM by using the command asmcmd. After entering asmcmd no command (for example: ls, cd, ..) was working. After some research I changed the following parameters:
export ORACLE_HOME=/opt/u01/oracle/product/12.2.1/grid
export PATH=$ORACLE_HOME/bin
export ORACLE_SID=+ASM
After changing the parameters the commands are working now. In /DATA/ there are the following files which I can find:
/DATA/ASM/ASMPARAMETERFILE/REGISTRY.xxx.xxxxxxxxx
/DATA/ORCL/PARAMETERFILE/spfile.xxx.xxxxxxxxx

According to this article https://juniororacledba.wordpress.com/tag/c...le-from-spfile/ I checked the location of the spfile:
SQL> show parameter spfile

NAME TYPE VALUE
---------------------------------------------------------------------------------------------
spfile string +DATA/ASM/ASMPARAMETERFILE/registry.253.937097749

I was surprised of the result, because I was expecting to find the SPFILE in the folder ORCL instead. But I tried to continue and create a PFILE from the SPFILE with the following command:

SQL> CREATE PFILE='/home/oracle/my_init.ora' FROM SPFILE'+DATA/ASM/ASMPARAMETERFILE/REGISTRY.253.937097749'
After hitting enter a new line shows up with the number "2" and waiting for some input from my end I think. Hitting again enter it finishes, but no PFILE was created.


Anyway is the started approach to fix this warning the correct one? If you think yes then what should I do to edit the SPFILE successfully


Best regards
1stone
Go to the top of the page
 
+Quote Post
burleson
post Mar 15 2017, 03:14 PM
Post #2


Advanced Member
***

Group: Members
Posts: 13,442
Joined: 26-January 04
Member No.: 13



Hi lstone and welcome to the forum!

>> Unfortunately the creation of a new database is producing some warnings during the database creation process:


Your core error is the ORA-00119 error, the setting for local_listener:

See here:

http://dba-oracle.com/bk_ora_00119.htm

Also, you need to get your spfile working:

http://www.dba-oracle.com/tips_oracle_spfile_example.htm




Good luck!




--------------------
Hope this helps. . .

Donald K. Burleson
Oracle Press author
Author of Oracle Tuning: The Definitive Reference
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

Lo-Fi Version Time is now: 28th June 2017 - 05:46 PM